Excel – Fehlermeldung vermeiden

In einer Tabelle werden für eine mehrtägige Fahrradtour die Strecken, das Datum und die Zeit aufgelistet. Die Zeit ist erst für die ersten vier Tage eingetragen, die Berechnung kann darum für die letzten drei Tage noch nicht möglich:

19.02.2015_ 0000

In Spalte D wird berechnet: Kilometer dividiert durch Zeit. Für die letzten drei Tage fehlt noch die Zeit, so dass eine Division durch Nichts gibt. Das besagt die Fehlermeldung #DIV/0.
Ich möchte zwar die Formeln komplett vorbereiten, aber ich möchte keine Fehlermeldung sehen.

Dafür gibt es die Funktion WENNFEHLER.

=WENNFEHLER(Wert;Wert falls Fehler)

In meinem Beispiel sieht die Formel für D2 so aus:

=WENNFEHLER(B2/C2;””)

Dividiere B2 durch C2, aber wenn ein Fehler auftritt, schreibe nichts (die beiden Anführungszeichen stehen für Nichts).

Der Aufbau ist immer gleich:

WENNFEHLER(Berechnung;Wert, wenn bei “Berechnung” ein Fehler entsteht)

Werbeanzeigen

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google Foto

Du kommentierst mit Deinem Google-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s