Excel–Mittelwert gewichtet

Bei einem Kunden werden Fragebögen aus vielen Veranstaltungen, Kursen und Seminaren ausgewertet. Zum Sachbearbeiter kommen pro Kurs die Mittelwerte zurück. Das sieht dann für einen Veranstaltungsort so aus:

 10.12.2016_ 0001

Für Seminar Nr. 1 wurden 14 Fragebögen erfasst und ausgewertet, die Mittelwerte aller 14 Bewertungen finden sich in B3 bis B8. Das Seminar Nr. 2 hatte 10 Teilnehmer und somit 10 erfasste Bögen, die Mittelwerte stehen in C3 bis C8 und so fort. Wie man sieht, gibt es Seminar mit sehr wenigen Teilnehmern (Seminare 15 bis 20, gelb hinterlegt) und solche mit vielen Teilnehmern wie Seminar Nr. 13 in Spalte N oder Seminar Nr. 22 in Spalte W.

Es sollen jetzt Gesamtmittelwerte gebildet werden und das stellte sich als Problem dar. Bei diesem Veranstaltungsort haben die schwach besetzten Gruppen der Seminar 15 bis 20 sehr schlechte Noten gegeben.

 10.12.2016_ 0002

Die Sachbearbeiterin hat zuerst den Mittelwert über alle Seminare ermittelt und dann probeweise einen Mittelwert ohne die kleinen Gruppen gebildet. Die Abweichungen waren gravierend. Es kam darum der Wunsch auf, den Mittelwert zu gewichten und den kleinen Gruppen nicht das gleiche Gewicht zu geben wie den großen Gruppen mit vielen Teilnehmern.

Die Berechnung erfolgt über SUMMENPRODUKT; für Zeile 3 “Sauberkeit” sieht die Berechnung so aus:

=SUMMENPRODUKT(B3:Y3;$B$2:$Y$2)/SUMME($B$2:$Y$2)

 10.12.2016_ 0003

Zuerst wird mit “SUMMENPRODUKT” jeder Mittelwert aus B3:Y3 mit der Anzahl der erfassten Bögen aus B2:Y2 multipliziert. Anschließend wird durch die Anzahl der erfassten Bögen dividiert.

Achten Sie auf die absoluten und die relativen Bezüge! Absolut wird immer auf die Zeile 2 Bezug genommen.

Ein Gedanke zu „Excel–Mittelwert gewichtet

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google Foto

Du kommentierst mit Deinem Google-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s