Excel – Alles zählen und in eine Zelle schreiben

In einer Liste wird erfasst, ob eine Person zugesagt (ja) oder abgesagt (nein) hat. Leere Zellen zeigen an, dass die Person noch nicht geantwortet hat. Die Antworten sollen gesammelt in einer Zelle angezeigt werden:

26.03.2017_ 0002

 

Die Antworten stehen in A1 bis A30. Für die Anzeige werden zwei Funktionen verwendet:

ZÄHLENWENN

ANZAHLLEEREZELLEN

Diese Funktionen werden  mit dem & (kaufmännischen Und) verbunden. Schritt für Schritt:

Alle “Ja” zählen:

=ZÄHLENWENN(A1:A30;”ja”)

Alle “Nein” zählen:

=ZÄHLENWENN(A1:A30;”nein”)

Alle leeren Zellen zählen:

=ANZAHLLEEREZELLEN(A1:A30)

 

Diesen Funktionen wird jeweils ein Text vorangestellt: zuerst das “Ja: “, dann “; NEIN: “ – das Semikolon schließt die Anzahl der Ja ab – und zum Schluss “; Ohne Antwort: “. Das & verbindet jeweils Text plus Funktion plus Text und so fort. Die gesamte Formel sieht zum Schluss so aus:

 

=„Ja: „&ZÄHLENWENN(A1:A30;“ja“)&„; Nein: „&ZÄHLENWENN(A1:A30;“nein“)&„; Ohne Antwort: „&ANZAHLLEEREZELLEN(A1:A30)

 

26.03.2017_ 0003

Werbeanzeigen

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s