Excel–Summewenn mit Platzhalter

SUMMEWENN war schon häufiger Thema in diesem Blog. Heute geht es um eine “unscharfe” Suche. In einer Liste werden Abteilungsabkürzungen über zwei Bereiche geführt: Die Abteilungen sind IT, HR, PR und QA; die Bereiche sind A und B. Es kommen jeweils beide Kombinationen vor – also IT-A und IT-B, HR-A und HR-B und so fort.

Mit SUMMEWENN sollen alle Beträge addiert werden für IT, HR etc., unabhängig von dem Zusatz A oder B.

11.07.2018_0000

Die Formel in E2 lautet:

=SUMMEWENN($A$2:$A$37;D2&“*“;$B$2:$B$37)

11.07.2018_0001

Achten Sie auf die absoluten Bezüge für den Bereich ($A$2:$A$37) und den Summenbereich ($B$2:$B$37). Damit wird es möglich, die Formel für die übrigen Abteilunge nach unten auszufüllen. Der Suchbereich (D2) bleibt relativ.

Für das Suchkriterium wird nicht nur der Inhalt der Zelle D2 verwendet, sondern mit einem Platzhalterzeichen kombiniert. In meinem Fall kommen immer zwei Zeichen: der Bindestrich und die Buchstaben A und B. Es wären zwei Platzhalter möglich:

? – genau ein Zeichen wird gesucht, ich müsste also zwei Fragzeichen verwenden

*- beliebig viele Zeichen werden gesucht, damit bin ich flexibel

Da die Platzhalterzeichen als Text gesehen werden, müssen sie in Anführungszeichen gesetzt werden. Außerdem muss das Platzhalterzeichen mit dem & an den Zellinhalt gekoppelt werden:

…;D2&”*”;…

Mit den Fragezeichen würde es so aussehen:

…;D2&”??”;

Liest man diesen Teil im Klartext, so lautet es: Suche nach dem Inhalt von D2 gefolgt von beliebigen Zeichen (*) bzw. gefolgt von genau zwei beliebigen Zeichen (??).

Mit dieser Art von Platzhaltersuche sind sie flexibel, wenn Sie für SUMMEWENN keinen eindeutigen Suchbegriff finden. Beispielsweise könnte ich auch nach den Bereichen A und B addieren. Die Bereiche schreibe ich in die Zellen D10 und D11. Dann lautet die Formel:

=SUMMEWENN($A$2:$A$37;“*“&D10;$B$2:$B$37)

11.07.2018_0002

Wenn Sie einen Teil aus der Mitte suchen, packen Sie das Platzhalterzeichen vor und hinter den Suchbegriff. Der Suchbegriff steht in D15:

SUMMEWENN($A$2:$A$37;“*“&D15&”*”;$B$2:$B$37)

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

w

Verbinde mit %s