Excel – Wie viele unterschiedliche Einträge

Das Zählen von Einträgen ist in Excel kein Problem, aber wie viele unterschiedliche Einträge habe ich? Das lässt sich mit einer Matrixformel ermitteln.

Eine Matrixformel hat die Besonderheit, dass sie mit STRG+SHIFT+ENTER abgeschlossen werden muss. Gekennzeichnet wird das in der Formel durch geschweifte Klammern am Anfang und Ende.

18.10.2018_0005In einer Liste stehen in Spalte A die Namen der Teilnehmer. Jeder Name kommt häufiger vor, weil sich  die Teilnehmer für mehrere Kurse angemeldet haben.

Wenn ich ermittle, wie oft jeder Name vorkommt, kann ich daraus den Anteil errechnen. Zuerst mache ich das in zwei Hilfsspalten – im zweiten Schritt zeige ich dann die ganze Berechnung in einer einzigen Formel in nur einer Zelle. Aber Sie können es besser nachvollziehen, wenn Sie sich zuerst die schrittweise Berechnung anschauen.

Spalte C berechnet, wie oft jeder Name vorkommt. Die Formel in C2 lautet:

=ZÄHLENWENN($A$2:$A$11;A2)

Die Formel wird nach unten ausgefüllt. Damit wird für jeden Namen ermittelt, wie oft er erscheint.

Spalte D berechnet, welchen Anteil der Name hat: 4 ist ein Viertel, 2 ist die Hälfte, 3 wäre ein Drittel. Die Formel in D2 lautet:

=1/C2

Auch diese Formel nach unten  ausfüllen. Diese Zahlen werden in D13 addiert und ergeben 3 – ich habe drei verschiedene Namen.

Diese Berechnung ist zwar korrekt, aber mit den beiden Hilfsspalten reichlich umständlich. Um alles in einer Formel zu kombinieren brauche ich die Funktionen SUMME und ZÄHLENWENN.

Die Formel in B12 lautet:

=SUMME(1/ZÄHLENWENN($A$2:$A$11;$A$2:$A$11))

18.10.2018_0006Die gesamte Formel wird mit STRG+SHIFT+ENTER abgeschlossen, wodurch die beiden geschweiften Klammern am Anfang und Ende erzeugt werden. Bei jeder Änderung an der Formel muss wieder mit STRG+SHIFT+ENTER bestätigt werden.

Diese Matrix-Berechnung zählt in einem Durchgang alle Einträge durch – es wird also nicht für jeden Namen jeweils ein Wert ausgegeben, sondern für alle Namen wird der Wert berechnet und Excel “merkt” sich den  Wert. Diese “gemerkten” Werte teilt Excel jeweils durch 1 und addiert sie dann alle.

Sie können die Beispieltabelle hier herunterladen.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google Foto

Du kommentierst mit Deinem Google-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s