Excel – SVERWEIS und formatierte Tabelle

In einem SVERWEIS wird auf eine formatierte Tabelle in einer anderen Arbeitsmappe verwiesen. Die Arbeitsmappe heißt “Quelle.xlsx”, die formatierte Tabelle “tblBasis”. Gefordert ist die Spalte 2.

21.01.2019_0000

In einer weiteren Arbeitsmappe (“Ziel.xlsx”) wird jetzt der SVERWEIS aufgebaut:

21.01.2019_0001

Im ersten Schritt habe ich die formatierte Tabelle in “Quelle.xlsx” markiert und mit dem  Tabellennamen gearbeitet. Die Schreibweise war dann so:

21.01.2019_0002

=SVERWEIS(A2;Quelle.xlsx!tblBasis[#Alle];2;FALSCH)

Das hat wunderbar funktioniert, so lange beide Arbeitsmappen geöffnet waren. Leider klappt das nicht, wenn die Quelle.xlsx geschlossen ist. Dann kommt es zu der Fehlermeldung #BEZUG.

21.01.2019_0003

 

Anders ist es, wenn ich den SVERWEIS mit Zellbezügen aufbaue:

=SVERWEIS(A2;[Quelle.xlsx]Tabelle1!$A$1:$B$11;2;FALSCH)

Jetzt kann Excel auch in die geschlossene Quelle.xlsx “gucken” und liefert immer noch das richtige Ergebnis.

exclaimation_1600_clr_6882Fazit

Die Verwendung von Zellbezügen ist zwingend notwendig, wenn Sie auf eine andere Arbeitsmappe verweisen. Der Verweis auf die formatierte Tabelle scheitert hier.

Werbeanzeigen

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google Foto

Du kommentierst mit Deinem Google-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s