Excel – Verweis andersrum

Der SVERWEIS wurde hier schon oft behandelt (z. B. hier und hier und hier). Der Grundaufbau ist immer der gleiche: der SVERWEIS durchsucht die erste Spalte der Matrix von oben nach unten nach dem Suchbegriff.

Was aber, wenn der Suchbegriff nicht in der ersten Spalte, sondern der ersten Zeile zu finden ist?

27.01.2019_0006

Hier steht die Raumnummer in der ersten Zeile – SVERWEIS scheidet also aus. Stattdessen kann man hier den WVERWEIS nehmen. “S” steht für Senkrecht, “W” für Waagerecht.

Es soll ausgegeben werden, welcher Dozent in Raum 4 ist:

27.01.2019_0007

Der WVERWEIS erfordert genauso wie der SVERWEIS:

  • Ein Suchkriterium: B8
  • Eine Matrix: A1 bis G4
  • Die gesuchte Zeile ist die dritte
  • Die Angabe, ob wir einen innerhalb eines Bereichs suchen oder nicht

=WVERWEIS(B8;A1:G4;3;FALSCH)

Werbeanzeigen

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google Foto

Du kommentierst mit Deinem Google-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s