Excel – Zwischensummen

In einer Liste gibt es Zwischensummen mit =SUMME(…), darunter soll eine Gesamtsumme berechnet werden. Excel hilft hier vorbildlich – Beispiel 1:

  • 10.02.2019_0000In B11 und B20 stehen jeweils Summen für die Zellen darüber
    =SUMME(B2:B10)
    bzw.
    =SUMME(B12:B19)
  • In B21 klicke ich auf AutoSumme und erhalte automatisch
    =SUMME(B20;B11)
  • Excel fügt also von  alleine eine Berechnung mit einem Mehrfachbereich ein.

 

 

 

 

 

Beispiel 2: Alternativ kann ich auch mit der Funktion =TEILERGEBNIS(9;…) rechnen. Das TEILERGEBNIS hatten wir gestern schon mal im Zusammenhang mit ausgeblendeten oder gefilterten Zeilen.

TEILERGEBNIS benötigt zuerst die Angabe der Funktion: 9 oder 109 steht für die SUMME. Da ich hier nicht mit ausgeblendeten Zeilen zu rechnen habe, ist es egal, welche der beiden Funktionen ich verwende (zum Unterschied habe ich gestern schon geschrieben).

  • 10.02.2019_0001Die Zwischensummen in B11 und B20 sind mit der Funktion
    =TEILERGEBNIS(9;…) erstellt.
  • Die Gesamtsumme in B21 ist ebenfalls mit dem TEILERGEBNIS berechnet – im Unterschied zur SUMME kann ich hier den gesamten Bereich B2:B20 adressieren!
    =TEILERGEBNIS(9;B2;B20)

Beim TEILERGEBNIS werden Ergebnisse aus TEILERGEBNIS nicht mitgerechnet.

Allerdings muss die Zwischensumme wirklich mit TEILERGEBNIS erstellt und nicht mit SUMME berechnet werden – sonst gibt’s alles doppelt!

 

Der Vorteil zur SUMME aus dem ersten Beispiel ist, dass ich für die Gesamtsumme einen ganzen Bereich verwenden kann und mich nicht darum kümmern muss, dass auch tatsächlich die Zellen mit den Zwischensummen verwendet werden.

 

 

10.02.2019_0002Beispiel 3: Und als letztes wieder (wie gestern  auch) die Funktion AGGREGAT. Wenn in der Liste Fehlerwerte ermittelt werden, weil z. B. Werte über den SVERWEIS herausgesucht werden und noch nicht alles vorhanden ist, scheitern TEILLERGEBNIS und SUMME.

Rechts ist die Berechnung mit TEILERGEBNIS zu sehen, wenn einige Werte als Fehler #NV zeigen. Zwischensumme und Gesamtsumme zeigen ebenfalls einen Fehler.

 

 

 

 

 

 

 

Anders ist es mit AGGREGAT für die Zwischen- und die Gesamtsumme. Ich möchte eine Summe (Funktions-Nr. 9) erhalten, auch wenn Fehlerwerte vorliegen (Options-Nr. 6 oder 3):

10.02.2019_0004=AGGREGAT(9;6;B2:B10)

bzw.

=AGGREGAT(9;6;B12:B19)

Damit werden die Zwischensummen ohne Fehlerwert berechnet. Die Gesamtsumme soll Fehler und bereits vorhandene Zwischensummen ignorieren (Options-Nr. 3).

Rechts sehen Sie das Ergebnis.

 

 

 

 

 

Und so sehen die Formeln aus:

10.02.2019_0003

Für die Zwischensummen habe ich die Option 6 verwendet (Fehlerwerte ignorieren). Ich hätte auch Option 3 (ausgeblendete Zeilen, Fehlerwerte, verschachtelte Teilergebnis- und Aggregat-Funktionen ignorieren) verwenden können.

Zum Angucken und Nachmachen die Arbeitsmappe zum Herunterladen: Zwischensummen

 

Werbeanzeigen

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google Foto

Du kommentierst mit Deinem Google-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s