Excel–SUMMEWENNS

Im Blog gestern haben Sie gesehen, wie Sie aus einer Liste mit SUMMEWENN nach einem Kriterium Zahlen addieren. Entweder nach Projektnummer oder nach Mitarbeiter-Kürzel.

22.05.2019_0003Heute geht es einen Schritt weiter: wir kombinieren in der Funktion SUMMEWENNS zwei Kriterien. Wie viele Stunden hat Mitarbeiter in auf Projekt 1234 geschrieben?

 

 

Für die Profis: Ja, ich weiß, das geht auch mit Pivot – aber heute soll es um die Berechnung mit einer Funktion gehen.

Die Ausgangsliste ist die gleiche wie gestern: Kürzel stehen von A2 bis A28; Projektnummern von B2 bis B28 und die Stunden von C2 bis C28.

Die Funktion SUMMEWENNS braucht zuerst den zu addierenden Bereich – bei SUMMEWENN ist das das letzte Argument, hier das erste. Denken Sie gleich von Anfang an daran, die Bereiche alle absolut zu setzen!

=SUMMEWENNS(zu addierender Bereich;…
=SUMMEWENNS($C$2:$C$28;…

Dann folgt der erste Kriterienbereich und das erste Kriterium – bei mir die Spalte mit den Kürzeln und die Zelle A32 mit dem ersten Kürzel:

=SUMMEWENNS(zu addierender Bereich;erster Kriterienbereich;erstes Kriterium;…
=SUMMEWENNS($C$2:$C$28;$A$2:$A$28;A32;…

Dann der zweite Kriterienbereich und das zweite Kriterium – Spalte B mit den Projektnummern und Zelle B32:

=SUMMEWENNS(zu addierender Bereich;erster Kriterienbereich;erstes Kriterium;zweiter Kriterienbereich;zweites Kriterium)
=SUMMEWENNS($C$2:$C$28;$A$2:$A$28;A32;$B$2:$B$28;B32)

Man könnte jetzt noch mehr Kriterien anhängen, aber ich habe nicht mehr Smile

22.05.2019_0005

Für den ersten Mitarbeiter sieht man jetzt, dass er nur auf zwei Projekten arbeitet.

Am einfachsten ist es jetzt, den Block nach unten zu kopieren und das Kürzel jeweils zu ändern:

22.05.2019_0006

Eine andere Anordnung wäre es, die Kürzel in Spalte untereinander zu schreiben und die drei Projektnummern als Spaltenbeschriftung darüber:

22.05.2019_0007

Wie muss die Formel aussehen, wenn Sie die Anordnung so haben? Der zu berechnende Bereich bleibt gleich, genauso die beiden Kriterienbereiche. Nur die Zellen für die zwei Kriterien sind anders. Können Sie die Formel so aufbauen, dass Sie nur eine Formel für in/1234 schreiben und die Formel sowohl nach unten als auch nach rechts kopieren können?

Grübel.

Denk.

Überleg.

Tipp vom Waschbär:

20190522_165706

Noch ein Tipp: Für die Kürzel muss was fixiert werden? Spalte oder Zeile? Und für die Projektnummer – Spalte oder Zeile?

=SUMMEWENNS($C$2:$C$28;$A$2:$A$28;A32;$B$2:$B$28;B31)

Aus A32 wird beim Kopieren nach unten A33, A34, A35 – aber beim Kopieren nach Rechts muss es immer A bleiben. Also Dollar vor dem $A.
Aus B31 wird beim Kopieren nach rechts C31, D31 – aber beim Kopieren nach Unten muss es immer 31 bleiben. Also Dollar vor der $31.

=SUMMEWENNS($C$2:$C$28;$A$2:$A$28;$A$32;$B$2:$B$28;$B$31)

Klar?

Download der Arbeitsmappe wieder hier: Summewenns

Werbeanzeigen

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google Foto

Du kommentierst mit Deinem Google-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s