Excel – Monatsende

Ausgehend von einem Datum ermittelt die Funktion MONATSENDE den letzten des Monats. In A1 steht der 01.10.2019 – MONATSENDE ermittelt den 31.10.2019.

Die Funktion hat zwei Argumente: das Ausgangsdatum und die Anzahl der Monate.

=MONATSENDE(A1;0)

ermittelt den letzten des gleichen Monats wie das Ausgangsdatum in A1.

=MONATSENDE(A1;1)

ermittelt den letzten des folgenden Monats aus A1.

question_mark_serious_thinker_500_clr_5562Wozu braucht man sowas?

Ausgehend vom Startdatum sollen alle Tage bis zum Monatsende ermittelt werden, aber nur bis zum Monatsende, nicht darüber hinaus. Da die Monate 28, 30 oder 31 Tage haben, will ich nicht umständlich abzählen. Ich will eine maximale Anzahl an Formeln erstellen und abhängig vom Startdatum soll am Monatsletzten Schluss ein.

20.10.2019_0004Ich habe in der ersten Zeile jeweils das Startdatum geschrieben. Darunter wird bis Zeile 31 mit der gleichen Formel der folgende Tag berechnet; für den Oktober hört es am 31. Oktober auf. Für den November am 30. November – der folgende Tag in B31 ist leer. Im Februar funktioniert es prinzipiell auch – am 28. Februar (2019) ist Schluss. Aber leider kommen dann zwei Zellen mit Fehlerwerten.

Die Formel bisher lautet:

=WENN(A1+1<=MONATSENDE(A$1;0);A1+1;““)

Im Klartext:

  • Wenn A1 plus 1 (also 01.10. + 1 = 02.10.)
  • ist kleiner gleich als das Monatsende von A1 des gleichen Monats
  • dann rechne A1 plus 1 (also den nächsten Tag)
  • sonst schreibe nichts (das sind die beiden Anführungszeichen

Diese Formel kann ich von A1 bis A31 ausfüllen. Je nach Startdatum in der ersten Zeile geht es jetzt bis zum 30. oder 31. – der letzte Tag bleibt einfach leer.

Aber im Februar gibt es ein Problem. Die Fehlermeldungen müssen noch abgefangen werden. Dazu gibt es WENNFEHLER. Wie muss man das einbauen?

=WENNFEHLER(WENN(A1+1<=MONATSENDE(A$1;0);A1+1;““);““)

In blau ist die bisherige Funktion, davor wird WENNFEHLER gesetzt und mit einem Semikolon und einem weiteren “Nichts” (die zwei Anführungszeichen) geschlossen.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google Foto

Du kommentierst mit Deinem Google-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s