Excel – Bestimmte Spalten addieren

In einer Tabelle soll nur jede zweite Spalte addiert werden. Bislang wird das gemacht mit der Formel
=SUMME(D2;F2;H2)

21.10.2019_0001

In der Realität ist die Tabelle sehr viel größer mit sehr viel mehr Spalten. Entsprechend hoch ist die Fehlerquote. Es kommt hinzu, dass sich die Spalten nicht immer so regelmäßig abwechseln. Manchmal gibt es eine Bemerkungsspalte. Dann werden die Projekte durch zwei, nicht durch eine Spalte getrennt. Außerdem können es auch mal vier oder fünf Projekte sein. Jedes Mal muss man daran denken, die neuen Projektspalten in die Formel zu integrieren.

Gefragt war also eine Formel, die die Summierung der Stunden dynamischer macht.

Wichtig ist, dass der Projektname immer identifizierbar ist – bei mir endet er immer mit einem “(h)”. Danach kann ich suchen.

Ich habe die Funktion SUMMEWENN verwendet.

Sie lautet in allgemeiner Schreibweise:

=SUMMEWENN(Bereich;Suchkriterium;Summe Bereich)

Der Bereich ist die erste Zeile – hier soll nach dem Suchkriterium gesucht werden. Ich begrenze den Suchbereich auf A1 bis M1. Es können hin und wieder ein paar Projekte mehr werden. Da ich die Formel später nach unten ausfüllen will, muss der Suchbereich absolut gesetzt werden: $D$1:$M$1

Mein Suchkriterium ist (h), allerdings mit beliebigem Text davor – also *(h). Das Sternchen ist ein Platzhalter für beliebig viele Zeichen. Außerdem muss Excel wissen, dass er einen Text suchen soll – also mit Anführungszeichen drumrum “*(h)”.

Die zu addieren Zahlen (das Argumente SummeBereich) ist erstmal die Zeile unter der Überschrift. Der Bereich muss gleich groß sein wie der Suchbereich – also D2 bis M2. Der SummeBereich muss gleich flexibel sein, wenn ich die Formel  nach unten ausfülle – aus D2 wird D3, dann D4 und so fort. Der Bezug bleibt also relativ.

=SUMMEWENN($D$1:$M$1;”*(h)”;D2:M2)

21.10.2019_0002

Ab sofort ist es egal, wenn noch weitere Spalten hinzugefügt werden, Excel sucht sich selber die Projektspalten anhand des Merkmals (h) heraus und addiert nur die.

21.10.2019_0003

Neu hinzugekommene Projekte sind auch kein Problem mehr – sie müssen nur innerhalb des definierten Bereiches sein. Ich habe lediglich bis Spalte M vorgesorgt, weil bei mir maximal fünf Projekte vorliegen.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google Foto

Du kommentierst mit Deinem Google-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s