Excel–Formeln auf zweitem Blatt ausgeben

Auf dem ersten Blatt werden Berechnungen gemacht, auf dem zweiten Blatt sollen die Werte und die Formeln im Klartext stehen:

27.10.2019_0000

Blatt 1 trägt den Namen “Berechnung”, Blatt 2 heißt “Formeln”. Der Name des ersten Blattes wird gleich bei den Formeln benötigt.

Verwendet werden die Funktionen ISTFORMEL und FORMELTEXT.

ISTFORMEL ermittelt, ob der Inhalt einer Zelle eine Formel ist oder nicht. Auf dem Blatt “Berechnung”  ermittelt ISTFORMEL(A1) den Wert FALSCH; ISTFORMEL(C2) ermittelt WAHR.

FORMELTEXT gibt die Formel im Klartext aus. Auf dem Blatt “Berechnung” gibt FORMELTEXT(C2) das Ergebnis =A2*B2.

Um die Ergebnisse auf ein anderes Blatt zu übernehmen, muss ich jeweils den Blattnamen dazuschreiben. Blattname und Zellbezug werden durch ein Ausrufezeichen getrennt. Ich schreibe also auf das Blatt “Formeln”:

=FORMELTEXT(Berechnung!C2) ergibt =A2*B2

Da FORMELTEXT den Fehler #NV ausgibt, wenn die angegebene Zelle keine Formel enthält, muss ich mit einer WENN-Funktion abfragen, ob eine Formel in der Zelle vorliegt oder nicht.

Ich beginne auf dem Blatt “Formeln” in Zelle A1 mit meiner Formel und fülle Sie dann nach rechts und unten aus.

=WENN(ISTFORMEL(Berechnung!A1)=WAHR; …
Wenn in Zelle Berechnung!A1 die Prüfung ISTFORMEL den Wert WAHR ergibt, dann …

=WENN(ISTFORMEL(Berechnung!A1)=WAHR;FORMELTEXT(Berechnung!A1);Berechnung!A1)
… schreibe den Formeltext aus dieser Zelle, sonst schreibe den Wert aus A1.

Im Beispiel wird also für die Zellen A1, B1 und C1 aus dem Blatt “Berechnung” ermittelt, dass keine Formel vorliegt – also muss der Zellinhalt geschrieben werden. Das gilt auch für die Zellen A2 und B2.

Für die Zelle C2 wird ermittelt, dass eine Formel vorliegt, also muss der Formeltext geschrieben werden.

27.10.2019_0001

Unschön ist, dass in A7 eine Null (0) ausgegeben wird – diese Zelle ist im Blatt “Berechnung” einfach leer. Sie hat von Haus aus keinen Inhalt.

Auch das kann ich abfangen.

Als erstes frage ich ab, ob die Zelle A1 leer ist – wenn ja, soll Excel auch nichts schreiben. Keine Null, kein gar nichts.

=WENN(Berechnung!A1=””;””;

Daran schließt sich die WENN-Funktion an, die wir oben verwendet haben:

=WENN(Berechnung!A1=””;””;WENN(ISTFORMEL(Berechnung!A1)=WAHR;FORMELTEXT(Berechnung!A1);Berechnung!A1))

27.10.2019_0002

Achtung! Bitte nicht für tausende von Zellen verwenden. Excel ist nicht der Schnellste, wenn mit einem Bezug auf ein anderes Tabellenblatt gerechnet wird. Geeignet ist diese Formellösung nur für überschaubare Berechnungen.

Zum Download gibt es die Datei natürlich auch wieder. Auf dem Blatt “Formeln” ist die erste Variante, auf dem Blatt “Formeln (2)” die endgültige Variante der Formel zu sehen: Formeltext

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google Foto

Du kommentierst mit Deinem Google-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s