Excel–Gänsefüsschen in Formel

Anführungszeichen braucht man in einer Formel beispielsweise, wenn Excel Text als Ergebnis ausgeben soll.

=WENN(A1>200;”ja”;”nein”)

14.11.2019_0000Wenn der Wert aus A1 größer als 200, dann schreibe ja, sonst schreibe nein. Ja und nein müssen in Anführungszeichen gefasst werden, sonst versucht Excel, die beiden Worte als Anweisung zu interpretieren.

Die – scheinbar – genau gleiche Formel in diesem Beispiel produziert aber einen Fehler. Warum bloß?

14.11.2019_0001Wenn man ganz genau hinschaut, sieht man zweierlei:

  • Ein grünes Dreieck am oberen linken Zellenrand
  • Eine etwas andere Form der Anführungszeichen

Fangen wir mit dem Dreieck an – die Dinger sind keine Zierde, sondern geben wichtige Hinweise auf das “Wieso” und “Warum” einer Fehlermeldung. Also bitte draufklicken und gucken!
In diesem Fall meldet Excel: “Fehler: Ungültiger Name”.

14.11.2019_0002Ein Klick auf “Berechnungsschritte anzeigen” zeigt bei der Auflösung von “ja” ein “#NV” und bei Auflösung von “nein” den Fehler “#Name”. Excel stört sich also eindeutig an ja und nein – und konkret an den Anführungszeichen.

Wie kommt es dazu?

Eingetippte Anführungszeichen in Excel sind gerade. Kopiert man aber eine Formel von irgendwoher und fügt sie in Excel ein, werden die Anführungszeichen häufig typographisch gemacht – besonders, wenn die Formel aus Word oder einem anderen Schreibprogramm (wie diesem Blog hier) stammt. Diese Anführungszeichen sind nicht ganz gerade, sondern etwas gebogen.

Ich habe mal die beiden unterschiedlichen Anführungszeichen gegenübergestellt:

14.11.2019_0003

Getippt: gerade; Kopiert: gebogen.

Mit der Funktion UNICODE habe ich ermittelt, welches Zeichen das jeweils ist: eindeutig zwei verschiedene Zeichen: 34 bzw. 8220

Fazit: Nix ist mit kopieren. Schreiben!

Aber wenn Sie richtig viele Formeln mit falschen Anführungszeichen haben, können Sie sie suchen und ersetzen.

  • Markieren Sie ein falsches Anführungszeichen und kopieren Sie es
  • Wählen Sie in “Start | Suchen und Auswählen | Ersetzen”
  • Klicken Sie in “Suchen nach” und drücken Sie STRG+V – das kopierte Anführungszeichen wird eingefügt
  • Klicken Sie in “Ersetzen durch” und tippen Sie das Anführungszeichen
  • Anschließend auf “Alle ersetzen” klicken

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google Foto

Du kommentierst mit Deinem Google-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s