Excel – Rechnen mit formatierten Tabellen

Die gleiche Tabelle wie gestern – mit einem Unterschied: die formatierten Tabellen beginnen jetzt entgegen meiner Gewohnheit nicht mit “tbl_…”. Ich verwende jetzt die Monatsnamen Januar, Februar, März. Dann kann ich weiter automatisieren.

30.01.2020_0011

Das Übersichtsblatt sieht noch genauso aus wie gestern. In A2 steht der Monatsname – und den möchte ich direkt in meiner Formel verwenden. Wenn der Tabellenname aus Zelle A2 stammt, kann ich die Formel einfach nach kopieren – aus A3 kommt dann der nächste Monatsname und so fort.

Benötigt wird neben SUMME die Funktion INDIREKT. INDIREKT verwandelt einen Texteintrag (hier den Monatsnamen aus A2) in einen Bezug oder einen Teil eines Bezuges.

Für die Summe der Spalte “Betrag” aus der Tabelle “Januar” benötige ich die Formel:
=SUMME(Januar[Betrag])

Den Tabellennamen will ich aus den Zellen A2, A3, A4 nehmen. Das besorgt INDIREKT
=SUMME(INDIREKT(A2

Es fehlt aber noch der Spaltenname in eckigen Klammern. Da das für alle Tabellen identisch ist, trage ich das Text dahinter ein – deswegen die Anführungszeichen. Das & steht für “hänge den folgenden Text an”.

Vollständig lautet die Formel
=SUMME(INDIREKT(A2&“[Betrag]“))

30.01.2020_0010

Das kann jetzt nach unten ausgefüllt werden – aus A3 kommt dann “Februar” und so fort.

Wie immer: wer gucken will, lädt sich die Datei hier herunter Formatierte Tabelle und INDIREKT

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google Foto

Du kommentierst mit Deinem Google-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s