Excel – Text und Zahl in einer Zelle

In einer Zelle sollen Text und Zahl kombiniert werden.

Hier habe ich in B10 das Wort “Summe:” und die Addition aller Zahlen von B2 bis B9 kombiniert.
Die Formel dazu lautet:
=”Summe: “&SUMME(B2:B9)

Nach dem Gleichheitszeichen wird in Anführungszeichen der Text geschrieben. Mit dem &-Zeichen wird der zweite Bestandteil angehängt: die Berechnung der Summe.

Sie können beliebig kombinieren: Text und Zellbezug, Text und Funktion, Funktion und Text. Die Schreibweise ist immer so:
=“Text“&Funktion
=“Zu zahlen:“&SUMME(B2:B9)

=“Text“&Bezug
=“Überweisen Sie „&B10

=Funktion&“Text“
=SUMME(B2:B9)&“ sind zu überweisen“

Vergessen Sie die Leerschritte nicht!

Das geht auch mit Formatierung:

Dafür muss eine weitere Funktion eingebaut werden: TEXT sorgt für die Formatierung. Die Formel sieht so aus:
=“Summe: „&TEXT(SUMME(B2:B9);“#.##0,00 €“)

Zuerst wieder nach dem Gleichheitszeichen der Text und das &-Zeichen für den zweiten Teil. Die SUMME wird jetzt eingebettet in TEXT. Die Funktion TEXT erfordert zwei Argumente:
=TEXT(Wert;Format)

Der Wert ist die Summe:
TEXT(SUMME(B2:B9); …

Das Format ist das Zahlenformat #.##0,00 € – Tausenderpunkt, zwei Nachkommastellen und das Eurozeichen. Alles eingefasst in Anführungszeichen:
TEXT(SUMME(B2:B9);”#.##0,00 €”)

Allerdings: Rechnen kann man damit nicht. Wenn mit der Summe weiter gerechnet werden soll, ist ein benutzerdefiniertes Zahlenformat besser. Das zeige ich Ihnen im nächsten Blog am Dienstag, den 24. November 2020.

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google Foto

Du kommentierst mit Deinem Google-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s