Excel–Uhrzeit auf 15 Minuten runden

Es werden Zeitdifferenzen zwischen einer  Anfangs- und einer Endzeit berechnet. In Spalte A steht die Beginnzeit, in Spalte B die Endzeit. In C wird gerechnet:

=B2-A2

11.10.2021-005

Also: Ende mit Anfang. Alle Zellen sind formatiert im benutzerdefinierten Uhrzeitformat mit Stunden und Minuten.

Das erreichen Sie so: Start | Zahlenformat | Zahlen | Benutzerdefiniert. Tragen Sie ein hh:mm. Achten Sie unbedingt darauf, die Buchstaben klein zu schreiben!

Die Dauer soll auf eine Viertelstunde auf- oder abgerundet werden. Aus 01:13 soll 01:15 und aus 01:32 soll 01:30 werden. Dafür wird die Funktion RUNDEN verwendet. Die Funktion erwartet zwei Argumente:

=RUNDEN(Wert;Anzahl der Stellen)

Der Wert ist die Dauer in Spalte C. Die Anzahl der Stellen gibt an, wie viele Nachkommastellen ich brauche: in meinem Fall gar keine, also 0 (Null).

Aber bevor wir runden können, muss die Uhrzeit noch in Viertelstunden zerlegt werden.

Überlegung:

  • Ein Tag besteht aus 24 Stunden
  • Er besteht aus 48 halben Stunden
  • und aus aus 96 Viertelstunden

Wenn ich auf eine Viertelstunden runden will, muss ich die Uhrzeit aus C2 mit 96 multiplizieren:

=RUNDEN(C2*96;0)

Das reicht aber noch nicht. Ich muss noch durch 96 dividieren, damit das Ergebnis stimmt:

=RUNDEN(C2*96;0)/96

11.10.2021-006

Genauso geht es, wenn ich auf halbe Stunden runden will. Bei halben Stunden muss ich mit 48 multiplizieren und dividieren:

=RUNDEN(C2*48;0)/48

11.10.2021-007

Und wie sieht es aus, wenn ich auf ganze Stunden auf- bzw. abrunden will? Dann ist der Faktor 24:

=RUNDEN(C2*24;0)/24

Es gibt die gleiche Rechnung übrigens aus, wenn Sie immer aufrunden oder immer abrunden wollen:

=ABRUNDEN(C2*96;0)/96
rundet immer auf die nächste Viertelstunde ab

=AUFRUNDEN(C2*96;0)/96
rundet immer auf die nächste Viertelstunde auf

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s