Excel – Absoluter Wert

Die Differenz zwischen zwei Zahlen errechnet man ganz einfach als B2-A2.

24.10.2021-003

Allerdings soll hier anhand der Differenz eine Warnung ausgegeben werden. Ist die Differenz größer oder gleich 2, soll eine Warnung ausgegeben werden.

Und hier entsteht ein Problem: Ist die erste Note wesentlich schlechter als die zweite, ergibt sich eine negative Differenz. Beispielsweise in Zeile 8: erste Note 5,0, zweite Note 2,5 – daraus gibt sich eine Differenz von -2,5 und es würde keine Warnung ausgegeben.

Wir brauchen also immer den absoluten Wert. Dafür gibt es die Funktion ABS.
=ABS(B2-A2)

24.10.2021-004

Jetzt werden alle Differenzen als positive Werte ausgegeben. Und damit kann meine WENN-Funktion weiterrechnen:
=WENN(ABS(B2-A2)>=2;”Warnung”;””)

24.10.2021-005

Wenn man die Funktion auseinandernimmt, sieht das so aus:

Differenz zwischen B2 und A2 =B2-A2
davon den absoluten Wert =ABS(B2-A2)
wenn der absolute Wert größer/gleich 2 ist =WENN(ABS(B2-A2)>=2;
dann schreiben “Warnung” =WENN(ABS(B2-A2)>=2;”Warnung”,
sonst schreibe nichts =WENN(ABS(B2-A2)>=2;”Warnung”,””)

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

Verbinde mit %s